ISPManager 5 - зависла после обновления

Admin

Administrator
Staff member
ISPManager 5 - зависла панель с ошибкой "core FATAL Library libmgr linked to lib/libmgr.so.5.122.0 conflicting with already loaded one"

# tail -f /usr/local/mgr5/var/ispmgr.log
Sep 15 09:28:08 [2192:1] core FATAL Library libmgr linked to lib/libmgr.so.5.122.0 conflicting with already loaded one

Ошибка говорит о том, что панень пытается повторно загрузить библиотеку libmgr.so.5.122.0, которая уже стоит. Это говорит в свою очередь про то, что при обновлении панель ISPManager 5 поставила дублирующий пакет coremanager-5.x, который нужно удалить.
Смотрим какие пакеты у нас стоят:
# rpm -qa | grep coremanager-5
coremanager-5.109.0-1.el7.centos.x86_64
coremanager-5.122.0-1.el7.centos.x86_64

Удаляем тот что старой версии - без его зависимостей:
# rpm --nodeps -e coremanager-5.109.0-1.el7.centos.x86_64

Обновляем заново ISPManager 5 и все его пакеты:
# /usr/local/mgr5/sbin/pkgupgrade.sh coremanager

Параллельно смотрим процесс обновления панели в лог файле:
# tail -f /usr/local/mgr5/var/pkg.log

В нем видно весь процесс установки панетов ISPManager 5

Updated:
coremanager-pkg-bind.x86_64 0:5.122.0-1.el7.centos
coremanager-pkg-ipset.x86_64 0:5.122.0-1.el7.centos
coremanager-pkg-mysql.x86_64 0:5.122.0-1.el7.centos
coremanager-pkg-php.x86_64 0:5.122.0-1.el7.centos
ispmanager-lite-common.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-awstats.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-bind.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-dovecot.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-exim.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-httpd-itk.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-logrotate.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-myadmin.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-mysql.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-nginx.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-php.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-proftpd.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-roundcube.x86_64 0:5.122.0-1.el7.centos
ispmanager-pkg-sieve.x86_64 0:5.122.0-1.el7.centos
ispmanager-plugins.x86_64 0:5.122.0-1.el7.centos

Проверяем результат:
# rpm -qa | grep coremanager-5
coremanager-5.122.0-1.el7.centos.x86_64

и в итоге - пробуем зайти в ISPManager 5 через 1500 порт либо порт который у вас установлен.
 
Top